New Rich Content Editor

The New Rich Content Editor is now available in all courses.


The New Rich Content Editor was released to all courses on January 4, 2021.  The New Rich Content Editor changes the look and feel of the editor so that it more closely resembles the familiar format of popular word processing/editing software.

What is new in the New Rich Content Editor?
  1. New look and feel - The new Rich Content Editor now has menus (Edit/View/Insert/Format/Tools/Table) which more closely resembles the menu structure found in most common word processing programs.
  2. Tool consolidation and updated icons - The new Rich Content Editor streamlines the tool bar by lumping together similar features.  This helps to declutter the tool bar and add room for additional items.
  3. No more Content Selector Panel - In the old editor, linking to other parts of your course or to files stored in your course sites Files area was handled via the Content Selector Panel to the right of the editor.  The new editor has shifted the Content Selector Panel features to menus and icons on the tool bar.
  4. When adding links to files in your course site's Files area:
    1. File Sorting/Filtering - Ability to sort and search for files when adding file links - When adding a link to a file stored in your course site's Files area, you can now use search and filtering (by date added or alphabetically by file name) to find the files you need.
    2. File Publish Status - When selecting files, you can easily see if the file you are linking to will be visible to your students.  
  5. Auto-Save - The new auto-save feature will save unsubmitted content in your browser cache for up to one day.  This means that if you are editing content and navigate away from the page before saving, as long as you revisit/edit that same page within one day, you will be able to preview and retrieve the auto-saved content that you were working on.
  6. More Keyboard Shortcuts - Users have access to more keyboard shortcuts for creating and editing content.
How do I turn on the new editor in my course?

The new editor will be turned on automatically in all courses in early January 2021.  But, if you are ready to use the New Rich Content Editor now, follow these steps in each course:

  1. Go to your course site in Canvas.
  2. In your course, click the Settings button [1].
  3. In the Settings area, select the tab for Feature Options [2].
  4. Find the RCE Enhancements toggle button [3] and click it so that it turns to the green check mark.
  5. Go use the New Rich Content editor!
Enable the New RCE in courses before January through your course site's Settings area

Need help using the New Rich Content Editor?

The New Rich Content Editor is quite a bit different from the class editor - click on a topic link below to find out the new way to do tasks you are familiar with:

Where did the Content Selector Panel go?

One of the benefits to the new Rich Content Editor is that it has collapsed the Content Selector Panel into the more familiar menu format that is used with most common word processing software and content editing tools.  Below you can see screenshots and descriptions showing where the classic editor's Content Selector Panel tools are now located in the new Rich Content Editor.

In the new Rich Content Editor, click on the Insert button [1] and then select Link [2].  When you select Course Links [3], the Add Links Slider [4] will appear on the right side of the screen where you can view, expand, and link to Canvas tools a activities in your course.  See more about inserting course links into the editor in the How do I link to a specific Canvas activity or Canvas tool? section of this article.

Content Selector Panel:  Files Tab

In the new Rich Content Editor, click on the Insert button [1] and then select Document [2].  When you select Course Documents [3], the Add Files Slider [4] will appear on the right side of the screen where you can view a list of all the files stored in your Files area.  See more about inserting file links into the editor in the How do I link to a document stored in my course site's Files Area? section of this article.

What about uploading a new file?

You can still upload new files directly from the editor - when you go to the Insert button [1] then select Document [2], you will then click on Upload Document [5] to open the Upload file popup [6].  See more about uploading files in the How do I upload a new file while editing content? section of this article.

Content Selector Panel:  Images Tab

In the new Rich Content Editor, click on the Insert button [1] and then select Image [2].  When you select Course Image [3], the Add Images Slider [4] will appear on the right side of the screen where you can view and select image files stored in your course site's Files area.  See more about inserting and embedding image files into the editor in the How do I insert and embed an image stored in my course site's Files area? section of this article.  You may also want to check out the section on How do I upload and embed a new Image (from your computer, from Unsplash free images, or via URL) white editing content? for details on inserting and embedding files that are not in your Files area.

How do I upload a new file while editing content?

Files that you upload through the New Rich Content Editor will be stored in your course site's Files area under an auto-generated folder called Uploaded Media.   Check out the section on How do I find the files I uploaded to Canvas via the New Rich Content Editor? for details.

  1. Place your cursor in the text box where you want your link or, if desired, highlight the words you want to be a clickable link.
  2. To get to the upload screen, open the upload files area by either:
    • Clicking on the Insert menu [1], selecting Document [2] and then Upload Document [3].
      OR
    • Clicking on the arrow to the right of the Document Tool Icon [4] in the tool bar and select Upload Document [5].
Upload and link to document in Files area via the Insert menu.
Upload and link to document in Files area via the Document Tool.
  1. The Upload File popup will appear.  Drag and drop your file onto the Upload File area [6] or you can click on the Upload File area [6] and browse your computer to find the file.
  1. Once the file is displayed on the screen, you can either click the Delete icon [7] to remove it or you can click the Submit button [8] to complete the upload and insert the link into the text box.
  2. When you are returned main page, click Save / Save and Publish to finalize your changes.

NOTE:  You can only upload one file at a time through the Upload File popup.

How do I insert and embed an image stored in my course site's Files area?
  1. Place your cursor in the text box where you want your image to appear.
  2. To get to the list of image files, open the course images (from Files) list by either:
    • Clicking on the Insert menu [1], selecting Image [2] and then Course Images [3].
      OR
    • Clicking on arrow to the right of the Image Tool Icon [4] in the tool bar and select Course Images [5].
Embed an image from the Files area via the Insert menu
Embed an image from the Files area via the Image Tool
  1. A slider drawer will appear on the right side of the screen displaying the images stored in your course site’s Files area. Click on the image file [6] you want to embed.
  2. Once you have clicked on the appropriate image file, the image will be embedded in the text box.
  3. When you are returned main page, click Save / Save and Publish to finalize your changes.
Use slider drawer to expand sections and select images to embed.

NOTE:  You can use the filter options drop down menus [7] to search for files or filter your files by type, Date Added or Alphabetical order. 

How do I upload and embed a new Image (from your computer, from Unsplash free images, or via URL) white editing content?

Image files that you upload from your computer through the New Rich Content Editor will be stored in your course site's Files area under an auto-generated folder called Uploaded Media.   Check out the section on How do I find the files I uploaded to Canvas via the New Rich Content Editor? for details.

  1. Place your cursor in the text box where you want your image to be embedded.
  2. To get to the upload screen, open the upload files area by either:
    • Clicking on the Insert menu [1], selecting Image [2] and then Upload Image [3].
      OR
    • Clicking on the arrow to the right of the Image Tool Icon [4] in the tool bar and select Upload Image [5].
Upload and link to image via the Insert menu.
Upload and link to image via the Image Tool.
  1. The Upload Image popup will appear.  You can upload an image in one of 3 ways:

OPTION 1:  Upload a file from your computer

  1. Select the Computer tab [6]
  2. Drag and drop your image onto the Upload File area [7] or you can click on the Upload File area [6] and browse your computer to find the file.
Click on or drag and drop files onto the Upload File popup

OPTION 2:  Select a copyright-free image from Unsplash

  1. Select the Unsplash tab [7]
  2. In the search bar [8], type in a description of the image that you want.
  3. Click on the image [9] you want to embed.
Search for and select an image from Unsplash

OPTION 3:  Enter the URL for an image

  1. Select the URL tab [10]
  2. In the search bar [11], type in a description of the image that you want.
Upload image via URL
  1. Once you have selected your image, you will now need to enter some additional information for your image.
    1. In the Alt Text box [12] provide some alternative text for your image - this is usually a textual description of what is depicted in your image which will be read to students using screen reading software.  
      NOTE:  If your image is not informational and is used for aesthetic purposes, select the checkbox for Decorative Image [13]. and you will not need to enter alternative text for the image.
    2. In the Display Options settings [14], select whether you want the image you are inserting should appear embedded on the screen or if you just want a text link that users will click on to open the image in a new tab.
  2. When you are done, click the Submit button [15] to complete the upload and insert the image.
  3. When you are returned main page, click Save / Save and Publish to finalize your changes.
Enter image attributes then submit your changes.

NOTE:  You can only upload one file at a time through the Upload Image popup.

How do I embed a video from my Media Library?

NOTE:  For Course Welcome Videos that you want visible to students via Yale Course Search, please skip to the next section on Insert Embed Code.

  1. Place your cursor in the text box where you want your video to be embedded.
  2. To get to the Media Library video list you can either:
    • Click on the Tools menu [1], select Apps [2] and then Media Library [3] (NOTE:  if you have not used Media Library recently, you may need to first click View All [4] and then find Media Library).
      OR
    • Click on the Media Library Icon [5] in the tool bar.
Insert Media Library file via the Tools menu.
Insert Media Library video via the Media Library tool icon
  1. The Media Library popup will appear.  Select the video file [6] you want to embed.

NOTE:  You can also use the Upload or Record tabs [7] to add or create a new video.

  1. Once you have selected the video, click the Insert button [8] and your video will be embedded into the text box.
  2. When you are returned main page, click Save / Save and Publish to finalize your changes.
Select Media Library video and then click insert
How do I insert an HTML embed code?

NOTE:  For Course Welcome Videos, you will want to get your video file’s Media Library embed code first and then follow the instructions below to insert the embed code into the Rich Content Editor.

  1. Place your cursor in the text box where you want to insert your embed code.
  2. To get to the Embed Code tool you can either:
    • Click on the Insert menu [1] and select Embed [2].
      OR
    • Click on the Embed Icon [3] in the tool bar.  (NOTE:  If your browser window is too narrow, you may need to click on the more tools (3-dot icon) first and then click on the Embed icon.)
Insert embed code via Insert menu
Insert embed code via Embed tool

NOTE:  If your browser window is too narrow, you may need to click on the more tools (3-dot) icon [A] first and then click on the Embed icon [B].

If the editor is not full sized, you may need to click the more tools icon first, then the embed icon
  1. The Embed popup will appear.  Paste code in the Embed Code box [4] provided and then click Submit [5].
  2. Once you have submitted, embed content should appear in the text box.
  3. When you are returned main page, click Save / Save and Publish to finalize your changes.
Paste embed code in the box and then click submit
How do I switch between the HTML view and the Rich Content Editor view?

Switch to HTML View

  1. When you are looking at the Rich Content editor you can either:
    • Click on the View menu [1] and select </> Raw HTML Editor [2].
      OR
    • Click on the </> icon [3] in the tool bar located just below the text box.
Switch to HTML view via the View menu
Switch to HTML view via the HTML View tool

Switch back to the Rich Content Editor

  1. Click on the </> icon [4] in the tool bar located just below the text box.
Switch back to Rich Content Editor via the HTML View tool
How do I find the files I uploaded to Canvas via the New Rich Content Editor?

When uploading files through the New Rich Content Editor, your files will be uploaded to the Files area in your course to an automatically generated folder called Uploaded Media.  

After you have uploaded your first file through the New Rich Content Editor, go to the Files area [1] and you will see a new folder for Uploaded Media [2].  Notice that the folder has publish permissions set to Only available to students with link (eye with slash indicator) [3] - which means that students who navigate directly to the Files area will not see the folder or its contents, but links to these files that instructors add via the New Rich Content Editor will allow students to view the files.

NOTE:  The Uploaded Media folder will only appear in the Files area after you have uploaded your first file through the New Rich Content Editor.